Page 1 of 1

Yts4000 riding lawn mower

Posted: Thu Nov 28, 2019 6:40 pm
by Deepakb
Hi all
I have a yts4000 riding lawn mower. battery ls fully charged, It take atleast 15- 20 clicks to start this.
When it is started i turn it off and able to start in just one click.

I dont understand why it takes 15 to 20 clicks to start this lawn mower initially. But when it is on i am able to mown the lawn, during the process i turn off the mower many times and it gets started in just one click.

Any idea why it takes 15 to 20 clicks initially. Whay could be the problem?

Re: Yts4000 riding lawn mower

Posted: Fri Nov 29, 2019 9:02 am
by Shannon
Does the motor have a choke? If so I would use it.
Other than that maybe the fuel pump is weak and after it sits for a while and the fuel drains back it takes a minute to get it back to the carb? Adding an inline primer may help that.

Re: Yts4000 riding lawn mower

Posted: Sun Dec 01, 2019 10:18 pm
by A. Spruce
It is unclear whether you have to crank the engine multiple times or if the key requires several turns to the start position before the engine will crank. Multiple cranking or prolonged cranking indicates a cold start issue, which is usually fuel related, check that the carburetor is clean and in good working condition and that fuel filters are clean.

Multiple twists of the key to get the starter to engage would indicate an electrical issue. I'd start with tracing every wire connection and make sure they are clean and making good contact. Next I'd trace down every safety interlock and make sure that it is functioning properly. Seat sensors are a huge problem. They are designed to disable the engine unless someone is sitting in the seat and they are notorious for going bad.

Re: Yts4000 riding lawn mower

Posted: Mon Dec 02, 2019 7:32 am
by Shannon
Hmm yes Spruce you are correct I was assuming that by "clicks" the OP was referring to the engine turning over.