Bizarre outlet reading....3 lights on receptacle tester

Ask your electrical related questions here
Post Reply
coopmancity
Posts: 15
Joined: Thu Mar 20, 2014 10:04 pm

Bizarre outlet reading....3 lights on receptacle tester

Post by coopmancity » Thu Apr 24, 2014 12:41 am

Hi,

I have an outlet the is getting a 120 reading if I test the load side and ground, but not when I test the load and neutral with a multimeter. However, when I plug in a receptacle tester all three of the LEDs come on, with the red dimmer then the two yellows. Anybody know what's up here?

Oh, of course nothing works on this outlet.

Thanks in advance

Coop

User avatar
Shannon
Posts: 13048
Joined: Fri Nov 25, 2011 11:58 pm
Location: Canada
Contact:

Re: Bizarre outlet reading....3 lights on receptacle tester

Post by Shannon » Thu Apr 24, 2014 7:31 am

Maybe a broken neutral wire? Are you using your multi meter on the wires or sticking it the receptacle holes? The receptacle its self could be faulty
If you've found our videos or website information helpful, please considering making a donation using PayPal or pledging us on Patreon

coopmancity
Posts: 15
Joined: Thu Mar 20, 2014 10:04 pm

Re: Bizarre outlet reading....3 lights on receptacle tester

Post by coopmancity » Thu Apr 24, 2014 11:31 pm

I am testing the outlet. I put a new outlet in so I know it's not that.

I think it may be a faulty neutral wire. If so am I out of luck?

Thanks!!

Coop

User avatar
Shannon
Posts: 13048
Joined: Fri Nov 25, 2011 11:58 pm
Location: Canada
Contact:

Re: Bizarre outlet reading....3 lights on receptacle tester

Post by Shannon » Fri Apr 25, 2014 7:24 am

Yes you will need to pull a new wire for that run, if you can.
If you've found our videos or website information helpful, please considering making a donation using PayPal or pledging us on Patreon

Post Reply