Page 1 of 1

Panel works but no burners work

Posted: Sat Mar 16, 2019 5:23 am
by Picisa
Hi.
I am wondering what is up with a problem I am having. My stove/ovenwith 4 burners stopped working but the panel lights up. ( clock etc)
So I got another oven and same problem. Is it the breaker? Or is it the wiring?

Re: Panel works but no burners work

Posted: Sat Mar 16, 2019 5:36 am
by christoff
The electrical people will be by in a bit,but I suppose you have looked at all of the breakers and they are on and there hasn't been any renovation work done to affect any damaging of the wiring, it could be a bad breaker.
Added: I don't know how handy you are but knowing if you had power at the stove receptacle plug would help a lot.

Re: Panel works but no burners work

Posted: Sat Mar 16, 2019 6:52 am
by emtnut
Picisa wrote:
Sat Mar 16, 2019 5:23 am
Hi.
I am wondering what is up with a problem I am having. My stove/ovenwith 4 burners stopped working but the panel lights up. ( clock etc)
So I got another oven and same problem. Is it the breaker? Or is it the wiring?
Sounds like you only have 1 leg of 120V (You need 2 legs to make the 240V)
It could be a bad breaker, or a bad connection at the stove receptacle.
If you have a multimeter and are comfortable working in the panel, you can check each pole of the 2 pole stove breaker.
With the power off, you can check the stove receptacle.

Re: Panel works but no burners work

Posted: Sat Mar 16, 2019 8:27 am
by Shannon
Things like stoves and clothes dryers are supplied by a 240 breaker but the appliances have components that use 120v only like the timers and display components and then the use full 240 for heating/drying components. So if you loose one leg (one 120v supply) then you will get no heat.